Hi,
I see errors randomly generated in log. It can occur any time during a day.
I did test port connections on both servers. Firewall is active but 6144 ports are defined properly on both servers/
Tested connections:
Main server:
root@domoticz1:~# nc -zv 10.10.3.10 6144
Connection to 10.10.3.10 6144 port [tcp/*] succeeded!
Remote server:
root@domoticz2:~# nc -zv 10.10.3.2 6144
Connection to 10.10.3.2 6144 port [tcp/*] succeeded!
Passwords are identical
Both systems running the latest beta version on Debian 13 (also updated and upgraded)
At random log messages on both systems:
2026-06-02 05:00:48.397 Error: DZ2: No data received from 10.10.3.10:6144 after 12 seconds. The remote Domoticz may be running an older version that does not support the SIGNv3 protocol. Please update the remote Domoticz instance.
What can I do?
SIGNV3 errors on main and remote server Topic is solved
Moderators: leecollings, remb0
Forum rules
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.
Use the following template when posting here:
Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....
If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly
If you are replying, please do not quote images/code from the first post
Please mark your topic as Solved when the problem is solved.
Before posting here, make sure you are on the latest Beta or Stable version.
If you have problems related to the web gui, clear your browser cache + appcache first.
Use the following template when posting here:
Version: xxxx
Platform: xxxx
Plugin/Hardware: xxxx
Description:
.....
If you are having problems with scripts/blockly, always post the script (in a spoiler or code tag) or screenshots of your blockly
If you are replying, please do not quote images/code from the first post
Please mark your topic as Solved when the problem is solved.
-
sloeber70
- Posts: 52
- Joined: Wednesday 08 July 2020 10:59
- Target OS: Linux
- Domoticz version: latest
- Location: Bruges
- Contact:
SIGNV3 errors on main and remote server
Kind regards,
Sloeber70
Linux Debian 13 standard edition
Domoticz latest beta on ProxmoxVE Virtual Machine
Sloeber70
Linux Debian 13 standard edition
Domoticz latest beta on ProxmoxVE Virtual Machine
-
f14driver
- Posts: 19
- Joined: Sunday 24 June 2018 16:19
- Target OS: Raspberry Pi / ODroid
- Domoticz version:
- Contact:
Re: SIGNV3 errors on main and remote server
I see the same message after starting the domoticz main server but it only appears once on the latsts stable 2026.2 version.
After the initial message it doesn't appears anymore until I restart the domoticz service.
Since I have a lot of remote servers it can take some time to get them all alligned (I have 28, I use domoticz to monitor the raspberry pi's).
All instances are running the same version, the message started after the update to the new version.
after clearing it it hasn't returned, only when I restart the process on the main server.
I think It tells you that the communication isn't completed yet within those 12 seconds.
Do you have timeouts in your network communication ?
After the initial message it doesn't appears anymore until I restart the domoticz service.
Since I have a lot of remote servers it can take some time to get them all alligned (I have 28, I use domoticz to monitor the raspberry pi's).
All instances are running the same version, the message started after the update to the new version.
after clearing it it hasn't returned, only when I restart the process on the main server.
I think It tells you that the communication isn't completed yet within those 12 seconds.
Do you have timeouts in your network communication ?
-
sloeber70
- Posts: 52
- Joined: Wednesday 08 July 2020 10:59
- Target OS: Linux
- Domoticz version: latest
- Location: Bruges
- Contact:
Re: SIGNV3 errors on main and remote server
Hi,
I think It tells you that the communication isn't completed yet within those 12 seconds.
Do you have timeouts in your network communication ?.
It could be that this occurs after the daily reboot of the second server. They do reboots daily at 03am (main) and at 05am(slave).
Maybe it can be a network disruption or a long script that is running on the main server.
I did not think of that.
Thanks for the suggestion.
I will look into it.
I think It tells you that the communication isn't completed yet within those 12 seconds.
Do you have timeouts in your network communication ?.
It could be that this occurs after the daily reboot of the second server. They do reboots daily at 03am (main) and at 05am(slave).
Maybe it can be a network disruption or a long script that is running on the main server.
I did not think of that.
Thanks for the suggestion.
I will look into it.
Kind regards,
Sloeber70
Linux Debian 13 standard edition
Domoticz latest beta on ProxmoxVE Virtual Machine
Sloeber70
Linux Debian 13 standard edition
Domoticz latest beta on ProxmoxVE Virtual Machine
-
sloeber70
- Posts: 52
- Joined: Wednesday 08 July 2020 10:59
- Target OS: Linux
- Domoticz version: latest
- Location: Bruges
- Contact:
Re: SIGNV3 errors on main and remote server
Issue is closed:
Is related to servers going offline during reboots or maintenance. (reboot, restarting services,....)
Is related to servers going offline during reboots or maintenance. (reboot, restarting services,....)
Kind regards,
Sloeber70
Linux Debian 13 standard edition
Domoticz latest beta on ProxmoxVE Virtual Machine
Sloeber70
Linux Debian 13 standard edition
Domoticz latest beta on ProxmoxVE Virtual Machine
-
goblin
- Posts: 41
- Joined: Sunday 23 July 2017 14:55
- Target OS: Raspberry Pi / ODroid
- Domoticz version: 2023.1
- Location: Haarlemmermeer
- Contact:
Re: SIGNV3 errors on main and remote server
hello all,
i just updated my slave RPI , not via sudo bash -c "$(curl -sSfL https://install.domoticz.com)" ) because i could not get that working but via copying it via winSCP . After this the Power and Gasy data is not "copied" to the from RPI 192.168.7 version 2026.2 to 192.168.9 version 2025.2 and have this info in the log.
Error: Remote Domoticz at 192.168.1.9 uses legacy protocol (SIGNv2, expected SIGNv3). Please update the remote Domoticz instance.
according "check for update" is 2026.2 a beta version.
any comment ?
i just updated my slave RPI , not via sudo bash -c "$(curl -sSfL https://install.domoticz.com)" ) because i could not get that working but via copying it via winSCP . After this the Power and Gasy data is not "copied" to the from RPI 192.168.7 version 2026.2 to 192.168.9 version 2025.2 and have this info in the log.
Error: Remote Domoticz at 192.168.1.9 uses legacy protocol (SIGNv2, expected SIGNv3). Please update the remote Domoticz instance.
according "check for update" is 2026.2 a beta version.
any comment ?